Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Convert to C++ results in linker error "undefined reference to _exit"

Using a simple CubeMX generated project, the project builds and debugs ok but when I do a Project “Convert to C++”, I get a link error “undefined reference to _exit”. Converting back to C works ok.

Already answered here: http://www.openstm32.org/forumthread739Question.

When converting to C++, linker .ld file reference needs to be changed from ${workspace_loc:/${ProjName}/LinkerScript.ld} to ..\STM32F407VGTx_FLASH.ld

This setting is found in Project / right-click menu Properties / node C/C++ Builder / Settings / tab Tool Settings / node MCU G++ Linker / General / field Linker Script (-T).

After this, I could link/debug etc. and I could rename my main.c to main.cpp and link/debug etc.


 

Newest Forum Posts

  1. openOCD Wrong device detected by maxim221, 12:32
  2. STM32429I_Discovery board with printf float support problem by johannes.visser@msc-technologies.eu, 2019-12-05 16:08
  3. malloc heap issue with CubeMX Project by johannes.visser@msc-technologies.eu, 2019-12-05 16:04
  4. Debugger not working by Daniel Jack Morley, 2019-11-27 21:46
  5. Compiler change problem by Lucian Pop, 2019-11-20 17:41
  6. Sample programs and compiling by jjtimer, 2019-11-20 10:31
  7. Unit test issues for STM32 by Rinkedevries, 2019-11-18 10:32
  8. Ubuntu 19.04 Debug problems by costantino, 2019-11-17 19:17
  9. Compile without eclipse by JSStabl, 2019-11-14 15:55
  10. Problem with PWM signal by ElectroniK, 2019-11-13 20:55

Last-Modified Blogs