SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

STM32duino bluepill bootloader can't upload code

I got a few bluepills to learn and test them, so i downloaded stm32duino bootloaders chose the correct one and flashed it to stm32 using stlinkv2(generic_fastboot_pc13.bin). Everything went well and bootloader led blinks when i reset it using the pushbutton. Also when i go for example to arduino ide it detects the port. But when i try to upload code to it it just timeouts and doesn’t upload. I tried all different upload methods and different boards even the fake chip option but nothing worked. I got booloaders from here ((https://github.com/rogerclarkmelbourne/STM32duino-bootloader|bootloader))
Any idea what’s wrong or what to check?

Best regards