SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Error: "Please install SW4STM32 toolchain to open the project. Or associate the file type of the project with your Toolchain in System Default Program Settings"

I am using STM32CubeMX to create a project. Once the below settings are established I click generate code and then select the option to open project I get the error message “Please install SW4STM32 toolchain to open the project. Or associate the file type of the project with your Toolchain in System Default Program Settings”. I cannot open the file from eclipse and the project is located in the folder in the settings as EEL452Lab1.ioc.

Does anyone know why Eclipse will not open the project? (Also I am running this on a mac.)

I am trying to install this too for the STM32MP1. The documentation is quite limited without much guidelines. Here is how far I have come
SW4STM32 is provided by OpenSTM as a plugin for Eclipse.

1. Install Java JRE (for Eclipe)
2. Install Eclipse (>= Mars)
3. http://www.openstm32.org/HomePageQuestion
4. Create an account
5. go to http://www.openstm32.org/System%2BWorkbench%2Bfor%2BSTM32Question
6. Take note of the commet for Macs!

P.S: It says you must install
sudo apt-get install libc6:i386 lib32ncurses5
but it’s not found on my ubuntu system and seems not neccessary..

Two options to install Workbench /Toolchain
1. Add the software in eclipse by the link as provided. ( http://ac6-tools.com/...)Question - i used this.
2. Download the installer
Here is the “.run” file listed that STM refers to.
chmod +x install_sw4stm32_linux_64bits-v2.9.run
This will install Ac6 Worbench in the folder you wish.

Then you van create a new or in your case open your project,
It seems you can find i when under the C/C perspective.
Create a new project
Select C/C++
Select the AC6 toolchain
Select the board

Ac6 pages are in French by default. Select the english icon... :-)


I am still getting the same error can anybody help i am using windows 10,what is this message trying to convey?

Hie got a workaround for this
In your eclipse ide you can add stm32 cubemx plugin by downloading from here
1.After that open eclipse
2.go to help/install new software
3.click on add ,in select archive add the path where your zip file is
4.click on ok and install that software in your eclipse IDE
video link to that

Also i am unable to solve the original posted problem if any one can help it would be great

associate .cproject file with Ac6. I don’t know how to do it on Mac but in gnome based linux make “application/x-SystemWorkbench=sw4stm32.desktop” entry to “/usr/share/applications/defaults.list”
I presume you have sw4stm32.desktop file in /usr/share/applications folder. If not make a desktop shortcut for Ac6 and name it sw4stm32 then copy that file to /usr/share/applications folder.
any modification on defaults.list file and/or copying a file to /usr/share/applications folder require root password.

SW4STM32 is not on ST’s website anymore as it is marked as obsolote. Could anyone please help me find it ?

Hi there,

I tried clicking multiple times to download the installer but nothing was downloaded. Could anyone help with the link or let me know the process/steps to download the exe file?

Thanks in advance :-)

I am unable to download the.exe for installing workbench