SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

For anyone who may be interested.

I completely deleted all the install directories (c:/Ac6) and all the project directories( c:/users/***/workspace/) and the libraries directories ( C:\Users\***\AppData\Roaming).
I downloaded the install again ( install_sw4stm32_win_64bits-v2.4.exe ) and re-installed everything.

Still the same error as shown in the png above.

I am on a Win7 Pro Dell Latitude E6520 with 8G of RAM.

Is there something wrong with this install on Win7 ?
Does the software really work ?


Hello Don Vukovic,

Please could you share your selected target ?

Could you share too firmware install step leading to such error pop up dialog ?. Firmware install process is going thru :
1) Local firmware install scan (see step1 within steps.png)
2) If no local firmware install detected resources download is performed(see step2 within steps.png). Some C:\Users\***\AppData\Roaming\Ac6\SW4STM32\firmwares.tmp_STM32FirmwareInstall_*** temp directory should be created
3) Once resources onboard, unzip process is done (see step3 within steps.png)
4) Following a clean up step firmware should be detected as locally installed then (see step4 within steps.png)

Feel free to share back.

United States




Thanks for detailed already sharing.
Same workflow is ending to some positive result on my side relying latest sw4stm32 release on windows 7 host.

Could you have a new try launching eclipsec.exe application instead eclipse.exe. Such will launch tool including windows console. Getting firmware install issue back you should get some stack trace in it ... sharing such back will definitively help to point issue.


I’ll save posting the new png files, the result is the same error.



From stack trace, sounds some native java command (files move) is failing. Such is invoked by sw4stm32 but no sw4stm32 code failing here. Move process is invoked by the end of firmware setup process to pick data from temporary (working) directory to final area.

Let’s have a look to : https://stackoverflow.com/questions/22988210/java-nio-file-accessdeniedexception-while-using-files-moveQuestion

Sounds some java setup issue too (should not be related to your move issue) : https://bugs.openjdk.java.net/browse/JDK-8139507Question

Let’s share back if helping ...

Loading the zip file into the firmwares directory has solved my problem.

Thank You for your help.



Good already to know you’re not stucked anymore.

If you have some extra time for, please could you have a try picking another target and / or Cube HAL type firmware to confirm still issue or not.
Such file move issue is weird: would be a pain if facing some trouble later within workflow about.
I’m not aware about your project constraints / STM32 eco system knowledge but please please notice standard peripheral libraries are not most up to date ones. HAL ones are recommended ones.


The firmware ‘STM32Cube_FW_F4_V1.19.0’ has been found.

Thank You again.


I have the same issue.

Dear Don Vukovic

Could you give link to STM32Cube_FW_F4_V1.19.0 for download ?


I encounter exacted same issue with yours

I currently has kaspersky installed, after disabling it i successfully installed the firmware

Hope this can help.

Has anyone found any solution or workaround for working under linux?

I seem to have the same thing - got Eclipse 2019-12 (4.14.0) and (through Eclipse) System Workbench for STM32 installed ok (running Mint 18.1), but I can’t get a single damned firmware to install, whatever I’ve tried. When creating a new project, I get as far as the “Project Firmware configuration” view, and none of the StdPeriph nor Cube HAL firmware options work. I select an option, I get the “Target firmware has not been found locally ..” text in read, click the “Download target firmware” button, agree to the “License Agreement” pop-up then ... nothing. It almost immediately vanishes and nothing further happens, no firmware.

I have tried copying both the zip and the unzipped versions of STM32Cube_FW_F0_V1.11.0 (downloaded from ST) into the Rc6 “firmwares” folders, under various names, with no result.
I have tried adding it to Eclipse as something to install from a local file with no result (fairly obvious now as it’s firmware not a plugin, which is why it complained about no .jar file ... but I was trying anything I could think of).
I have tried modifying Eclipse Network Connection settings with no result (now back on “Native” as the default) - but then the Marketplace works fine, as did the System Workbench install, so this seems more like an issue with the firmware stuff than a network issue.
I have tried running Eclipse as root (!), with no result. (Same non-results after clicking the “Download target firmware” button / agreeing to the “License Agreement”. Same failure to identify downloaded files.)
I’m out of further ideas, whether my own or what found from the forums or google.

Hi Junker!

I am currently facing the same problems and have described my findings in a parallel thread right HEREQuestion

However, no success so far.. From my perspective it could also be a server problem (is the file on the server? which server? can we get its url or something?). The locally downloaded (or upacked) zip files never get touched or taken into account :-(

Do you guys realize that many people are having this issue and that your software does not work if this is not solved?

Has an official solution been posted for this problem?

Given the number of threads open on this exact issue and the deafening silence... ‘tempted to say that if “they” are there at all, they know, ‘just don’t care.

Fwiw I appreciate efforts from folks on here trying to help, but I’ve better things to do than wait for the ST chips to be made usable again. While my ST boards are sat on a shelf collecting dust, I’ve had an ESP8266 up and running, serving web-pages and blinking neopixels, with a choice of command line gcc or Arduino IDE both functioning. And several other manufacturers’ ARM dev board to work on next. Whatever’s going in the next product I design, ‘can’t say it’s likely to be an ST while the tools are in this state ...

I would recommend all of us who do not want to waste time fighting with the firmware installation issue to switch to STM32CubeIDE.

STM32CubeIDE is introduced by ST as their official IDE. It is presented as the line of Atollic TrueStudio, after Atollic was acquired by ST. It is Eclipse-based as well and looks very solid-made.

It seems that the partnership between ST and ac6 is no more alive, therefore we experience problems with support.

Well, yes and no.
The stm32cubeIde makes you work with HAL only. If you have an ongoing project and lot of your libs based on SPL then sw4stm32 is your only feasible option, imo.
I’ve just quick-tested the stm32cubeIde and can’t see no other option than HAL.