SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

You are viewing a reply to debugger won't start : again !  

debugger won't start : again !

This error message is totally useless out of context. We need to know “context of what”. What part of eclipse ( or the ac6 additional software ) is reporting this? What is the context a context of?

My guess is that this is a bug where a null or undefined pointer is being passed. But without more intelligent error trapping and more informative error messages there is just about zero possibility of knowing where this is coming from or how to fix it.

We don’t even know where to file a bug report. Is this eclipse or the ac6 software ? No way to know.

Very poor quality.


Hi Estie, from your message is far away to learn or help you.
Please report more information:
Operating system where IDE are running
Complete console error text.

About “again” is working in the past? what is changed?

IDE? What part of eclipse ( or the ac6 additional software ) is not clear to you in a forum about “System Workbench for STM32 ” ?

The IDE is cross-platform java , so should be OS independent, I still need to know what this “context” is supposed to mean.

OS is Fedora Linux FWIW.

I did post a second msg with more info but the forum seems to have lost it. ;(

What has changed is that I was fool enough to update eclipse. This always ends up in a run-around cycle of reinstallation and debugging the debugger.


estie> I did post a second msg with more info but the forum seems to have lost it. ;(

I don’t see it

estie> What has changed is that I was fool enough to update eclipse. This always ends up in a run-around cycle of reinstallation and debugging the debugger.

This way is quite impossible to help you, please calm down and provide clean information.
I also got in trouble updating toolchain, what I am doing is to show developer what happened in a clean way as sysadmin to users.
Fedora is linux and environment is not same on other platform also if you think java is same an all platform, so please provide full console text to direct you about debugging of. Otherwise I simply quit.
Best regards

The following problem occurs when trying to start debugging:
Error in final launch sequence
Reset command not defined for device ‘Generic TCP/IP’

Install sw4stm as Eclipse Oxygen plugin. Previously, everything worked fine, and with the last installation, such a problem arose.

I tried this on similar Fedora system, which , sadly, I had already updated and thus got the borked “oxygen2” version alreadly installed.

In this case, despite selecting both the ac6 suite and the “external tools” the cross debugger is not present ! It compiles the project but fails to launch the debugging session.

It reports “unable to start debugger, reason unknown”.

UNKOWN? Like it can not even work out that the executable it is calling is not there ?

What the heck are they doing with the errors codes , just ignoring them apparently.

This is not exactly the same errors as was getting on the other ( main development ) system,but also results in the debugger failing.

Roberto, if you have experience with trouble with the toolchain update, it would be helpful if you could be more specific or provide a link to any bug reports if you have contacted the devs.

I previously used the distro’s cross compiler suite and told eclipse not install just the ac6 tools, it still dumped their toolchain on the system and now seems to have removed it without installing the update. It’s frankly a mess.

This may be time for me to quit this crippled dinosaur IDE and find another dev. system. I’ve had it with spending more time debugging other peoples tools that using them.

I just installed the distro gdb so the link in the eclipse config is now pointing to a valid cross-gdb.

Low and behold I now get the same “invalid context” crap that I originally got on the main system.

I’ve had with this flakey ac6 stuff. Hopefully the Attolic aquisition will give STM32 devlopers an alternative.

I’m now looking at other OSS debugging environments. I’d be better off working with a good code editor like Geany and CLI debugging by hand.



According to the post above (thanks kratos3946) this seems to be an Eclipse CDT bug. You can try to revert CDT to an older release, and keep us informed on the result. There was a release on December 20, just before you got this problem, so reverting to the previous release may be enough.

I agree this is disturbing but we are not responsible of bugs introduced by Eclipse and cannot test all Eclipse releases, in all configurations and on OSes. Right, Eclipse is cross-platform Java code, but both GUI toolkit’s and system interface (like network) are platform dependent, and your problem obviously fall into this category... That’s why we need information like OS, OS version, Java version, Éclipse version, etc.

Hope this will help,

Bernard (Ac6)

many thanks for that info. it does look like the same problem.

May I take the opportunity to point out that a lot of the problem was the totally vague error message. It seems that the error trapping and reporting could be a lot more helpful.

I will report back on whether this resolves the issue.

no, this does not seem to be the same issue. The distro CDT is still at 9,3,2

Eclipse GDB Hardware Debugging

Build id: @build@

I have two systems both running Fedora 26 and essentially in the same state. The above output was from the laptop that I have been using off-site recently.

Returning to the main system I found that it was using CDT 9.4 , this seems to be pulled in by the ac6 installation process and the distro eclipse-CDT was not installed. This does display the TCP/IP error known to affect 9.4 .

To revert this to 9.3, I installed the distro eclipse-CDT package and then restarted eclipse. It now shows CDT 9.3 . However, the TCP/IP error is still occurring.

‘’Error in final launch sequence
Reset command not defined for device ‘Generic TCP/IP’‘’

Time to drop this unreliable mountain of abstraction layers and poorly maintained packages and get back to simple command line debugging, which will probably be ten times faster and more reactive.

No. This whole situation is a mess.

I have one system working but the other one shows this message and is running 9.3.2 which is supposed to be before the update which caused the problem. I was getting a different “invalid context” error before.

I have given up on ac6 closed source, poorly tested and unmaintained debugger and am moving over to using geany editor on linux.

It is possible to get all the arguments to build from command line by looking at the debugging console. I’ve blocked eclipse from updating in case it craps on me again.

I was never happy about relying on blindly installing “unsigned” prorietory software into eclipse. This have just motivated me to do something about ti.