Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Firmware Installation Process Issue: Not able to establish connection to remote host!

Same problem as I have. After installation of SW4STM32 and F4Discovery-FW everything was fine. But with the installation of CubeHAL-FW the problem started. The Discovery-FW (StdPeriph lib) is consequently ignored. I’ve checked the firmware installation properties and tried to add the location explicitely on first position. But it didn’t solve the problem.

I made a screenshot wallpaper showing everything. It is attached as PDF.

The error message might come from the attempt to overwrite the existing installation. But why is it then a loss of connection?
Maybe there is something with the “repository sharing helper”.

Hi, two pcs install error ! (download finish error: Not able to establish connection to remote host!)
have solution it problems ?

thanks,
Carlos.


France

Sorry for the inconvenience; there was a problem with the STM32F4 firmware file signature in the firmware definition. Please update your installation (Help >> Search for updates...) and this should be corrected.

Bernard (Ac6)

hi Bernard,
Solved !
install Sw4stm32 ,
-> updates.....OpenStm32 IDE ok,
Firmware download and install ok.

thanks,
Carlos.

Your solution works

Same issue, even updates is unable to resolve this issue.
Eclipse IDE for C/C++ Developers

Version: Neon.3 Release (4.6.3)
Build id: 20170314-1500