Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32


Firmware Installation Process Issue: Not able to establish connection to remote host!

Happy Halloween!

I just installed the system work bench for STM32 using the installer. I am trying to create my first project and want to add the standard peripheral library. When I try to download the target firmware I get this error.

“Firmware Installation Process Issue: Not able to establish connection to remote host! Have you tried to revisit network connections preference settings?”

How can I get around this error?

Thanks,

Danielle

I have the same issue with the Ac6 eclipse from installer and also with my Eclipse Oxygen I added the plugins to.

Cube HAL Download and Installation seems to work, only StdPeriph Installation fails

Same problem as I have. After installation of SW4STM32 and F4Discovery-FW everything was fine. But with the installation of CubeHAL-FW the problem started. The Discovery-FW (StdPeriph lib) is consequently ignored. I’ve checked the firmware installation properties and tried to add the location explicitely on first position. But it didn’t solve the problem.

I made a screenshot wallpaper showing everything. It is attached as PDF.

The error message might come from the attempt to overwrite the existing installation. But why is it then a loss of connection?
Maybe there is something with the “repository sharing helper”.

Hi, two pcs install error ! (download finish error: Not able to establish connection to remote host!)
have solution it problems ?

thanks,
Carlos.

Same problem as well. The bizarre thing is I installed it fine on my other pc a couple weeks ago without issue.

Even if I download the firmware on my working pc and manually insert it into my \AppData\Roaming\Ac6\SW4STM32\firmwares repository on my non-working PC I still get the message “Target Firmware has not been found locally, please install it”

Hoping someone finds the solution.

France

Sorry for the inconvenience; there was a problem with the STM32F4 firmware file signature in the firmware definition. Please update your installation (Help >> Search for updates...) and this should be corrected.

Bernard (Ac6)

hi Bernard,
Solved !
install Sw4stm32 ,
-> updates.....OpenStm32 IDE ok,
Firmware download and install ok.

thanks,
Carlos.

Your solution works

Same issue, even updates is unable to resolve this issue.
Eclipse IDE for C/C++ Developers

Version: Neon.3 Release (4.6.3)
Build id: 20170314-1500


Thanks for letting me know that it worked on your pc a couple weeks ago lsiempelkamp! I checked the release date of the latest version and it was on Oct 25th so I decided to try reverting to version 2.2 and... It worked! I downloaded install_sw4stm32_win_64bits-v2.2.exe from here http://www.ac6-tools.com/downloads/SW4STM32/Question.
Verified. Updating my PC to the most recent version causes the issue. Reverting backwards to previous release fixes it. Good find Danielle!

hi,

it seems to have an issue in checking MD5 in some STD libraries.
You can try :
- to use SW4STM32 2.2
- to use HAL libraries (STD are old and not updated)

We are working on this issue ASAP, sorry for this
Christelle


Hi,

A new version has been released and is available through Eclipse update system (“Help > Check for Updates”).

This patch release v2.3.1 integrates:
* An update of the STM32Cube F4 HAL
* A fix for STD Periph download issue

Christelle

Thx Christelle, that works.
But unfortunately the new stm32cube_fw_f4_v1180 isn’t recognized by STM32CubeMX yet. I guess you have access to the developing team. Would you please inform them about this release.


Just installed system workbench and I am having this same problem. I cannot get firmware to download when trying to create my first project. Both the stdperiph and the cubehal exhibit the problem of showing the license agreement, seemingly starting the download, and then quickly showing the “not able to establish connection to remote host” message box.

The workbench is whatever the latest version is as of today (I am not sure which component’s version is at issue, there are 8 AC6-provided features each with their own version).

I am on the latest version of Windows 10.

The log in .metadata shows nothing interesting. No errors, exceptions, etc.

I am able to access the Eclipse marketplace from within the workbench/Eclipse.

Do I need the stdperiph or HAL firmware in order to actually program the board — use the UART, GPIO pin input/output? Or are there examples somewhere showing how to do this without a ‘firmware’?

France

Hello tedmil,

Sorry for late reply. Is such issue still valid ?

I would definitively recommend HAL firmware usage. Std periph are legacy firmwares: no maintenance, no support, not STM32CUbeMx compliant ...

Have you tried STM32 firmware remote server connection test within dedicated preferences page ? (see attachment)

Br.