SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

[SOLVED] Linux Version : Hangs on Build Setting


I installed the Linux version 1.8 (32bit) on Mint 17.3 which is based on Ubuntu 14.04 LTS.

After updating it, i imported a project from windows version (Nucleo L152RE Board) and it builds and runs ok.

But there is a problem :

if i goto

Project Properties >> C/C++ Build >> Settings

Which is the compiler setting window , Eclipse CPU Usae goes to almost 100% and it will became unresponsive. I left it for a few minutes and still high cpu load and unresponsive.

I had to kill it and run it again, but no matter what, it happens if i go to that setting page.

I even created a new project, but it happened again and i can’t access that page.

Is there any solution for this?


I would like to reproduce your issue. Can you tell if the which version of JavaRE is running ?

Can you also tell me if the project was created from System Workbench for STM32 on Windows or if it was generated with STM32CubeMX ?


Hello Kevin,

1) This is software version information on both Operating systems  :

Windows : Java 7 update 80 - My Systemworkbench is v1.3 (eclipse Luna) with updated plugins (v1.9)
I also installed Eclipse Mars + AC6 sytems Plugins seperately (v1.9) and there was no problem in this version too.

Linux : Linux Mint 17.3 Rosa Based on Ubuntu 14.04 LTS
JRE : Openjdk-7-JRE 7u101-2.6.6-0ubuntu0.14.04.1
System Workbench : V1.8 (Eclipse Mars) updated to V1.9

2) This Project was created by System Workbench for STM32 on Windows.
I copied the Full Project Directory to Systemworkbench workspace directory in linux, Set Appropriate Permissions and imported the project to System Workbench For Linux.

It builds without any error, i can program it to the Nucleo Board and it runs correctly,
But i can’t go to the compiler setting page because eclipse cpu usage goes to 100% and become unresponsive and i have to kill it.

Thank you for your help,


It seems that i can’t go to compiler setting page in any project. (in Linux Version)

I just created a new project and when i click to go to setting page, same thing happens again!

This is not new. I have the same configuration on the linux side and I have timed how long is takes to get to the settings. 4 minutes. If there is no project and i create a new project that is just a C - Hello world with Linux GCC it does the same thing. My java is :
OpenJDK Runtime Environment (IcedTea 2.6.6) (7u101-2.6.6-0ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode)

I typically go to settings to fix an include path or set the optimization. So my work around is to open (in the project root) the .cproject file (xml) and edit/add/delete the includes and any other setting I need. Then restart eclipse.

My eclipse MARS.2 version does not hang on the Project>C/C++Build>Settings on the same machine. However I have not yet set that up for STM32.


use a wrapper like this:


cd /home/db/eclipse/cpp-mars/eclipse/
export SWT_GTK3=0; ./eclipse


Hello Dieter,

Thank you vey much. This trick worked!

BTW, Shouldn’t we report this problem to eclipse.org or it’s a known bug? or Is it AC6 System Plugin bug?

If I might add for those who have installed via the installer which places an icon for SW4STM32 on the desktop:
1) add a new file to the Ac6/SystemWorkbench location, where the eclipse executable is located, called eclipse.sh or whatever you want to call the script then click on the file properties and set the permissions to executable.
2) add a line to the new file:
export SWT_GTK3=0; home/user/Ac6/SystemWorkbench/eclipse
where user is user location from the root where Ac6 was installed. If you changed the path entirely during install then use that path.
3) find the icon for system workbench on the desktop and right click to select properties.
4) in the “Command” edit box add .sh to the end of the line so it reads:

Thank everyone for the feedback.

I will add a new FAQ entry for current users. This issue has been reported and will be fixed on the next installer version.

Regards !


Hi everybody,

Just to be sure, what version of Mint Rosa do you use? Cinnamon, MATE, Xfce or KDE? Obviously there was an incompatibility with the window toolkit but I would like to be able to check exactly what is the source of the problem.

Bernard (Ac6)

Hello Bernard,

As i said before my software version, My Linux Mint version 17.3 Rosa MATE. ( everything is 32 bit version)

BTW, I also check with Official Oracle Java 8 update 91 for linux and the problem still exists.

Also after waiting about 7 minutes to open setting window (all the time with high cpu usage) , if i click on the TARGET tab , the samething happens again and i have to wait a long time or kill the IDE.

with the trick and using gtk2 instead of gtk3 ,everything seems fine for now.

A more generic aproach:
Add the line

export SWT_GTK3=0

at the end of /home/user/.profile

You have to logout and login once to take this in effect.