SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

System Workbench Compile error


For any kind of project that i am trying to compile, i am getting same error:
21:40:21 **** Incremental Build of configuration Debug for project STM32F4xx ****
make all
‘Building file: ../startup/startup_stm32f407xx.s’
‘Invoking: MCU GCC Assembler’
The system cannot find the path specified.
make: *** startup/startup_stm32f407xx.o Error 1

21:40:22 Build Finished (took 406ms)
any suggestions ???


Do you have resolve your trouble?
Because, I am the same error.


Hi Benoit,

the problem was the name of my folder.
my original project folder name was “elecronics & computers”. ater i changed it to “elecronics_computers” the problem solved.
try to change your project folder name and make sure that its not containing any symbols.
i hope its the same problem like yours.



No work for my, I’ve a new error.

18:06:32 **** Incremental Build of configuration Debug for project Test_Project ****
make all
sh: C:\Program: No such file or directory
make: *** startup/startup_stm32f407xx.o Error 127

18:06:33 Build Finished (took 1s.173ms)

Same for me. Used the latest installer and installed it in C:\Ac6...


try to avoid using space in your path. For example “C:\Program Files\Ac6” is not a good path.


It work.
I don’t know what is the problem, but it is OK.
Thank you all.


‘’11:52:06 **** Build of configuration Debug for project test2 ****
make all
sh: C:\Program: No such file or directory
make: *** startup/startup_stm32.o Error 127

11:52:06 Build Finished (took 129ms)’’

Same problem. No spaces in installation path: C:\STMicroelectronics\SystemWorkbench

Check the project path (not the installation path)


Workspace path is C:\Users\Zend\workspace_stm32wb
Project path is C:\Users\Zend\workspace_stm32wb\project

I dont have any other ideas.sorry
I have the same error. I generated the project in CubeMX. Pthe problem is in the generated files. C:\Users\ondra\workspace.ac6\testcube\wtm\SW4STM32\wtm Configuration There is a space. I dont know how to rid of it.

I am also facing the same problem, error 127 as shown below

11:32:22 **** Build of configuration Debug for project sw4stm32_gpio ****
make all
C:\Program: C:\Program: No such file or directory
make: *** Src/main.o Error 127

11:32:39 Build Finished (took 16s.913ms)

Software workbench installation path is, E:\ProgramFiles\Ac6\SystemWorkbench
Installation path doesnot have any space.

Even dummy project created using STMCubeMx doesn’t have space,
project path is : E:\Ashish\myfolder\GenX\STM32\CubeMx_Workspace\temp_ex\sw4stm32_gpio

i don’t know how should i proceed, please guide

I am facing the same error ..PLEASE HELP

09:36:56 **** Build of configuration Debug for project STM32469I_DISCOVERY ****
make all
C:\Program: C:\Program: No such file or directory
make: *** Example/User/main.o Error 127

09:36:56 Build Finished (took 226ms)

Hello I got the same problem (error 127). You should try to change the external builder to internal builder in project properties (look for C/C++ Build tab).

Good luck guys :-).

I know this is an old post, but I had the same issue, moved everything to become path without spaces in the folder names.
Everything worked afterwards.
Had my project in my documents folder and the IDE iin AC6 folder on root, which as you can see caused the problem.
So the project folder can not have spaces in its path.
Need confirmation through if this is an eclipse issue,which I believe so as my search for such problem returned originally C++ posts about similar error.
One other thing, I realized that my code compiled and uploaded to my STM micro, which is weird since the error was appearing after the upload. Not sure what exactly was happening in the background for this error to appear, which makes sense to investigate further.
I would really appreciate some feedback on this if anyone can elaborate on the inner workings of this.