SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Re: workspace woes how to add a project

Error in final launch sequence
Failed to execute MI command:
-target-select remote localhost:3333

Error message from debugger back end:
localhost:3333: The system tried to join a drive to a directory on a joined drive.
localhost:3333: The system tried to join a drive to a directory on a joined drive.

When I tried to debug as an AC6 project.
Using a nucleo with STLINK, but I cannot find that option in the debugger.



How did you create your project?
Did you follow th eprovided Tutorial?
Without more details we can’t help you...


Same problem here with the STM3240G-EVAL. With one caveat. All was working find at one point then it just stopped. My memory is not too clear, but I think I tried a clean installed and it worked again briefly. Then busted. I confirmed that the board uses ST-LINKV2.

I have the same problem.
No solutions?

Also the same Problem with den STM32L152 Nucleo

same problem with a STM32VL, target STM32F100, sound like nobody wants to solve that.


Could you describe your problem more precisely, giving the version of System Workbench you are using and, if not yet done, update it (Help >> Check for updates).
The original post dates back to more than 6 months ago and a lot of bugs and quirks has been corrected in the meantime.
If you still have problems, please start a new thread, with the above informations. Just saying “I have the same problem” six months after the OP will probably not get any sensible answer on any forum, especially if the OP effectively get an answer to his problem (see the posts following the one on which you complained by reading the full thread, not just an intermediate answer)...