Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Hardware Abstraction Layer(Cube HAL) not available

When creating a new SW4STM32 project, the option Hardware Abstraction Layer(Cube HAL) is not allowed to select, only Empty and Standare Lib allow to select under Project configuration page.
It worked for the first project created. Any comments for this issue?

Junbo

Hi Junbo

Can you tell me which board did you choose to create your project. The HAL firmware for this board might not be supported in the current version of System Workbench for STM32.

If so, it will supported in the next version that will be release really soon.

Kevin.

Kevin,
I’ll chime in and say that I’d like to see these two boards supported as soon as possible. In order of priority:

1) STM32F072RB-Nucleo
2) STM32303C-EVAL

Regards,
Dave

HI,

I still cann’t figure out why HAL is disabled when I created project for my own board with STM32F103C8.
I am running System Workbench for STM32 64-bit Windows version 1.0 for Windows 7.
Is there a newer version for Windows 7?

Thanks.

Junbo


Hi Dave,

The two boards you mentioned should be supported. Do you have the same issue as Junbo (HAL not allowed)? On which system are you running System Workbench (Windows or Linux)?

By the way, a new version has been released today. Please check for updates, it might fix your problem.

Let us know if you still cannot create/debug for these boards.

Best regards,
Kevin

Thanks Kevin - I see that now after doing an update yesterday.

I do have an issue though: in trying to check for updates today, a bunch were found and after selecting them all and moving ahead with the screens, I get and error. The details of the error are:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.cpp, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,fr.ac6.mcu.debug,1.1.0.201503101252
No repository found containing: osgi.bundle,fr.ac6.mcu.externaltools.arm-none.win32,1.1.0.201503101257
No repository found containing: osgi.bundle,fr.ac6.mcu.externaltools.win32,1.1.0.201503101257
No repository found containing: osgi.bundle,fr.ac6.mcu.firmware,1.1.0.201503101252
No repository found containing: osgi.bundle,fr.ac6.mcu.ide,1.1.0.201503101252
No repository found containing: osgi.bundle,fr.ac6.mcu.ldeditor,1.1.0.201503101252
No repository found containing: osgi.bundle,org.eclipse.cdt.debug.gdbjtag,7.0.0.201502131403
No repository found containing: osgi.bundle,org.eclipse.cdt.debug.gdbjtag.core,8.4.0.201502131403
No repository found containing: osgi.bundle,org.eclipse.cdt.debug.gdbjtag.ui,7.1.0.201502131403
No repository found containing: org.eclipse.update.feature,fr.ac6.feature.mcu.debug,1.1.0.201503101252
No repository found containing: org.eclipse.update.feature,fr.ac6.feature.mcu.externaltools.armnone.win32,1.1.0.201503101257
No repository found containing: org.eclipse.update.feature,fr.ac6.feature.mcu.externaltools.openocd.win32,1.1.0.201503101257
No repository found containing: org.eclipse.update.feature,fr.ac6.feature.mcu.externaltools.win32,1.1.0.201503101257
No repository found containing: org.eclipse.update.feature,fr.ac6.feature.mcu.ide,1.1.0.201503101252
No repository found containing: org.eclipse.update.feature,fr.ac6.feature.mcu.ldscript,1.1.0.201503101252
No repository found containing: osgi.bundle,fr.ac6.mcu.externaltools.openocd.win32,1.1.0.201503101257
No repository found containing: org.eclipse.update.feature,org.eclipse.cdt.debug.gdbjtag,8.6.0.201502131403


Can you restart System Workbench (to reload the update sites) and retry ?

Does it still display exactly the same error message ?

Tang,
I just tried that and got the same error. Network or Websense problem?
DT


Hi Dave,

We’re still investigating but it seems to be a network configuration problem. The fact that you cannot collect neither System Workbench plugins nor Eclipse plugins make me think your web filter is blocking the update.

Kevin.

That’s my hunch as well. I’ll be taking the laptop home tonight and trying it over my ISP connection and will let you know - I’d say don’t spend any more time on this until I can do that.
Thanks,
DT

Kevin,
Here’s an update: a collegue here tried the exact same process and had no problems. That points to my laptop, which is Win7-64. I then tried running SWB as administrator, but still get the same problem. Any other ideas? I mght try reinstalling from srcratch...
DT

Ok, final word on this is that a reinstall fixed the problem - I actually couldn’t uninstall the app due to a Java problem, so I hacked away at it manually. I also removed and reinstalled Java runtime 64 bit. Thanks for the help...
DT


I am using 64-bit Windows version SW4STM32 IDE on Windows 7 PC for STM32F103C8 on my own hardware.
When creating a SW4STM32 project, the option Cube HAL is disabled, not allow me to select this option for the project.

It works for STM32F091C.
I learned that SW4STM32 is supporting all STM32 family.

Meanwhile, CubeMX could generate init codes with HAL functions for STM32F103Cx.
This mean the firmware is there for STM32F103Cx, but why Cube HAL is not allowed in SW4STM32?

Thanks.


Junbo

France

Hi Junbo,

The STM32F103 is supported on System Workbench but was only released quite recently; could you update your IDE (Help >> Check for Updates...) and test again?

Bernard