Loading...
 

STM32MP1 support available in SW4STM32

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4; you can download a short video showcasing this on the ac6-tools website (registration required).

System Workbench for STM32


More openocd setup problems. No script specified or findable

Have a STM32L100-DISCO connected, and up. ( The STLink utility can connect )

I just installed the fresh version of SW4STM32 ( febr. 2019 )

Created a sample project with CubeMX and lauched the code generator and opened SW4STM32 from there
When starting a debug session, error appear, which might be related to a missing script :

Open On-Chip Debugger 0.10.0-dev-00015-gaaf1808 (2018-11-13-13:07)
Licensed under GNU GPL v2
For bug reports, read
	http://openocd.org/doc/doxygen/bugs.html
srst_only separate srst_nogate srst_open_drain connect_assert_srst
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter_nsrst_delay: 100
adapter speed: 240 kHz
Info : clock speed 240 kHz
Info : STLINK v2 JTAG v31 API v2 SWIM v0 VID 0x0483 PID 0x3748
Info : vid/pid are not identical: 0x0483/0x374B 0x0483/0x3748
Info : using stlink api v2
Info : Target voltage: 2.911429
Info : Stlink adapter speed set to 240 kHz
Info : STM32L100RCTx.cpu: hardware has 6 breakpoints, 4 watchpoints
Info : accepting 'gdb' connection on tcp/3333
Info : Stlink adapter speed set to 240 kHz
adapter speed: 240 kHz
target halted due to debug-request, current mode: Thread 
xPSR: 0x01000000 pc: 0x08000138 msp: 0x20000458
STM32L: Enabling HSI
Info : Stlink adapter speed set to 4000 kHz
adapter speed: 4000 kHz
Info : Device: STM32L1xx (Cat.3 - Medium+ Density)
Info : STM32L flash size is 256kb, base address is 0x8000000
Info : Stlink adapter speed set to 240 kHz
adapter speed: 240 kHz
target halted due to debug-request, current mode: Thread 
xPSR: 0x01000000 pc: 0x08000138 msp: 0x20000458
STM32L: Enabling HSI
Info : Stlink adapter speed set to 4000 kHz
adapter speed: 4000 kHz
Error: JTAG failure
Error: Error setting register
Error: JTAG failure       (  more of the same ....)


So I tried specifying the OpenOCD Options in de the debug setup:
-f st_board\stm32l100c_disco.cfg

which then logs :

embedded:startup.tcl:60: Error: Can't find st_board/stm32l100c_disco.cfg
in procedure 'script' 
at file "embedded:startup.tcl", line 60


Stuck ....