Loading...
 

System Workbench for STM32


Can't initalize data in bank2 at flash time.

Hi

Conf
W7 SP1
AC6 1.10.0.201607251855
STM32L152ZET6

I need some arrays in bank2 of the flash memory. Based on the map file, the data at the correct
place and when inspecting the hex file, it ok too.
But when flashing with AC6, the data is not correctly initialized.
When flashing with STLink Utility, it is ok.

Here’s the declaration of the arrays :

attribute((section(“.arrayFlash”))) uint32_t flashData200 = { 6, 8 , 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10};
attribute((section(“.arrayFlash”))) uint32_t flashStrings100 = {4, 2, 3, 4, 5, 6, 7, 8, 9, 10, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10};



Here’s the linker file:


/* Entry Point */
ENTRY(Reset_Handler)

/* Highest address of the user mode stack */
_estack = 0x20014000; /* end of RAM */

/* Generate a link error if heap and stack don’t fit into RAM */
_Min_Heap_Size = 0x200; /* required amount of heap */
_Min_Stack_Size = 0x400; /* required amount of stack */

/* Specify the memory areas */

/*
FLASH_BANK1 (rx) : ORIGIN = 0x8007000, LENGTH = 228K
FLASH_BANK2 (rx) : ORIGIN = 0x8040000, LENGTH = 256K

  • /


/* FLASH (rx)  : ORIGIN = 0x8007000, LENGTH = 228K
FLASH_BANK2 (rx) : ORIGIN = 0x8040000, LENGTH = 256K */

MEMORY
{
FLASH (rx)  : ORIGIN = 0x8007000, LENGTH = 228K
FLASH_BANK2 (rx) : ORIGIN = 0x8040000, LENGTH = 256K
EEPROM_BANK1 (rx) : ORIGIN = 0x8080000, LENGTH = 8K
EEPROM_BANK2 (rx) : ORIGIN = 0x8082000, LENGTH = 8K
RAM (xrw) : ORIGIN = 0x20000000, LENGTH = 80K
}

/* Define output sections */
SECTIONS
{
/* The startup code goes first into FLASH */
.isr_vector :
{
. = ALIGN(4);
KEEP(*(.isr_vector)) /* Startup code */
. = ALIGN(4);
} >RAM AT> FLASH

/* The program code and other data goes into FLASH */
.text :
{
. = ALIGN(4);
*(.text) /* .text sections (code) */
*(.text*) /* .text* sections (code) */
*(.glue_7) /* glue arm to thumb code */
*(.glue_7t) /* glue thumb to arm code */
*(.eh_frame)

KEEP (*(.init))
KEEP (*(.fini))

. = ALIGN(4);
_etext = .; /* define a global symbols at end of code */
} >FLASH

/* Constant data goes into FLASH */
.rodata :
{
. = ALIGN(4);
*(.rodata) /* .rodata sections (constants, strings, etc.) */
*(.rodata*) /* .rodata* sections (constants, strings, etc.) */
. = ALIGN(4);
} >FLASH

.ARM.extab  : { *(.ARM.extab* .gnu.linkonce.armextab.*) } >FLASH
.ARM : {
__exidx_start = .;
*(.ARM.exidx*)
__exidx_end = .;
} >FLASH

.preinit_array  :
{
PROVIDE_HIDDEN (__preinit_array_start = .);
KEEP (*(.preinit_array*))
PROVIDE_HIDDEN (__preinit_array_end = .);
} >FLASH
.init_array :
{
PROVIDE_HIDDEN (__init_array_start = .);
KEEP (*(SORT(.init_array.*)))
KEEP (*(.init_array*))
PROVIDE_HIDDEN (__init_array_end = .);
} >FLASH
.fini_array :
{
PROVIDE_HIDDEN (__fini_array_start = .);
KEEP (*(SORT(.fini_array.*)))
KEEP (*(.fini_array*))
PROVIDE_HIDDEN (__fini_array_end = .);
} >FLASH

/* used by the startup to initialize data */
_sidata = LOADADDR(.data);

/* Initialized data sections goes into RAM, load LMA copy after code */
.data :
{
. = ALIGN(4);
_sdata = .; /* create a global symbol at data start */
*(.data) /* .data sections */
*(.data*) /* .data* sections */

. = ALIGN(4);
_edata = .; /* define a global symbol at data end */
} >RAM AT> FLASH


/* Uninitialized data section */
. = ALIGN(4);
.bss :
{
/* This is used by the startup in order to initialize the .bss secion */
_sbss = .; /* define a global symbol at bss start */
bss_start = _sbss;
*(.bss)
*(.bss*)
*(COMMON)

. = ALIGN(4);
_ebss = .; /* define a global symbol at bss end */
bss_end = _ebss;
} >RAM

/* User_heap_stack section, used to check that there is enough RAM left */
._user_heap_stack :
{
. = ALIGN(8);
PROVIDE ( end = . );
PROVIDE ( _end = . );
. = . + _Min_Heap_Size;
. = . + _Min_Stack_Size;
. = ALIGN(8);
} >RAM



.arrayFlash :
{
. = ALIGN(64*4);
*(.arrayFlash)
. = ALIGN(64*4);
} >FLASH_BANK2


/* Remove information from the standard libraries */
/DISCARD/ :
{
libc.a ( * )
libm.a ( * )
libgcc.a ( * )
}

.ARM.attributes 0 : { *(.ARM.attributes) }
}



What should I do?

Thanks
Julien

Hello,

There has been an update recently for the dual bank devices STM32L0, STM32L1 and STM32F1 so you should update the software plugins first (v1.12.0).
With menu Help => Check For Updates.

Regards,
Laurent


Hello Laurent

Thanks for your answer.
It seems that there’s no automatic update available.
As screenshot, you’ll get all version numbers.

Is 1.12 the version of “ac6 c/c++ embedded dev tools for mcu” ?
If yes, I’m not able to get more that 1.10.

I also tried to re-install the latest from ac6 web page. I always get the
same version

How should I do ?

Thanks
Julien

The version is the one of the “ide” plugin so yes, it is “ac6 c/c++ embedded dev tools for mcu”.

When you do the “Check for Updates”, do you have a msg popup saying “No updates were found” ?
Or you have an error msg after ?


Yes, “no updates were found”.

One more info, I’ve just done a new installation on ubuntu.
On linux, I’m able to get an update to 1.12....


update to 1.12 worked on win8

I uninstalled everything on the win7 workstation.
reinstalled SW with installer.
Did check for updates.
Here’s the screenshot related to the available versions. 1.10 is the highest available.

OK, can you try to remove the directory .eclipse in your user directory.
And then relaunch the SW4STM32 and retry the Check for Updates.

Ok, I add to recreate the project and fix some compilation issues but now, it works.

Thanks a lot
Julien

Hello,
OK, but the plugins, did you succeed to update to v1.12 finally ?

Did you have to remove the .eclipse directory ?

Rgds,
Laurent

Yes and Yes.
And that fixed the bank2 issue.

a+
Julien

Ok, thanks for the update (answer)...lol